Jump to content

Keeps crashing


MarcA
 Share

Recommended Posts

I have an ongoing problem with PV Sol crashing. For example, I am currently designing a setup with 7440 solar modules in the 3D simulator, and while the autosave is being performed, the program hangs/crashes. This happens on almost every project I work with, most often at some point after I perform the shadow calculations. I have tried running the software on a different PC but I have the same result. I am using Windows 10 Pro, 8Gb RAM, PV*SOL premium 2020 (R10). Is there a way to fix this problem other than simply disabling the autosave feature? Thanks.

Link to comment
Share on other sites

Hi Marc,

if you didn't receive an email with a reference number, the error was thrown in the 3D environment. But I found the error in our logs (ref nr. 0178262, just for me to remember).

The problem here is really that the process is out of memory. PV*SOL is a 32bit process which means that there is a limit of around 1.3 GB of RAM. If you send me the project I could have a look if there is a possibility somewhere to save memory (by private message please).

Kind regards,

Martin

Link to comment
Share on other sites

Hi Martin,

That won't be necessary, thanks. We generally simulate large solar installations (in the order of megawatts) which means we will continue to hit our head on this ceiling. Are there future plans to increase the capacity of PV*SOL so that it can comfortably accommodate and process larger installations?

Regards

Marc

Link to comment
Share on other sites

Hi Marc,

thank you for sending the project. In my case I was able to go into 3D, configure the modules, change the configuration a bit, go back, calculate the shadows and then simulate the whole system without a problem. RAM usage was moderate, also during autosave. The highest peak was around 900 MB. Could you describe in which situations the program crashes?

Also, I realized that PV*SOL is using my GPU a lot during the shading calculations. Perhaps you have a dedicated GPU in your computer as well? If so, try configuring PV*SOL to use the better GPU, like so (example is for NVIDIA, but I guess for other manufacturers it is similar):

grafik.png

Kind regards,

Martin

Link to comment
Share on other sites

Hi Martin,

To answer your question, the crashes happen most often during an autosave process (at any point throughout the simulation process), or else when I try a manual save after the inverter connections are done. I think the GPU might be my problem as I am running from a laptop with an intel uhd graphics 620 which isn't exactly high performance hardware. My next step is to run it on a PC with a half decent GPU and see if I can do it without problems. 

I'll keep you updated.

Regards

-Marc

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...