Jump to content

2020R2 bug - horizon on report


Recommended Posts

Hi,

 

I think I may have found a bug on the presentation report.

Using the 3D design module I have loaded this realistic horizon into the project:

image.png.81462914b66eea1ba271f7a424195613.png

When generating the report back on the main program window, this is what gets generated:

image.png.a18b84523348b663d909c00e594952cd.png

Now apart from the obvious error of not using the 3D horizon, I am left with the more important doubt about the yield results, since obviously the correct horizon has impact on the determined values and I wonder which of horizons was used, if the 3D real horizon or the flat one from the report.

Can you please investigate and provide feedback on this?

Thank you.

Link to post
Share on other sites

Hi Joao,

I just verified again that in our test environments the 3D horizon function works as expected. Could you please provide an examplary project where this error occurs? You send it via private message here. Please be aware that it might take us a while to reproduce the issue. Most likely we won't be able to provide an answer before Monday.

Kind regards,

Martin

Link to post
Share on other sites

Hi Joao,

just a short feedback: I can reproduce the problem with your projects, and I haven't found the reason for this behaviour yet, but what I can say so far is that it doesn't affect the simulation results. And there is also a way to make it visible in the project report again.

  1. Load your project, go to results page, see in the energy balance "PV energy (AC) minus standby use", it is 128738,39 kWh
  2. Go to presentation page, create the report -> your horizon is not visible
  3. Go to 3D environment, Terrain View, right click on Horizon, open and close it with OK, and say OK to the warning "This action deletes the results of the shading simulation".
  4. Go back to PV*SOL, let the shadowing simulation run again
  5. Go to results page again, see in the energy balance "PV energy (AC) minus standby use", it is still 128738,39 kWh
  6. Go to presentation page, create the report -> your horizon is visible now

We will look into the reason why the horizon lines disappears in step 1 and 2, but this will be next week. We are sorry for the inconvenience this may cause.

Kind regards,

Martin

 

  • Thanks 1
Link to post
Share on other sites

Judging by your test case it would seem to be a problem related to some change in the way the project is being saved on 2020R2 vs 2019R14.

This project was originally created on 2019R14, hence my suggestion.

Next week will be fine, don't worry, this is not a blocking issue at this stage.

Thanks for the quick feedback.

 

EDIT: Tried your suggestion of removing and adding back the horizon and it worked. You can change the priority of this bug to "minor" as far as I'm concerned.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...